Ir para conteúdo
solarwind12

Vão conseguir arrumar as caracteres bugadas?

Recommended Posts

Aparentemente apenas tópicos antigos antigos estão bugados, espero que arrumem pois incomoda muito ler tudo bugado, mas acho difícil que arrumem

Compartilhe esta postagem


Link to post
Share on other sites

Para resolver esse erro, a maneira mais fácil, é subir de novo o backup do fórum e mudar o charset no campo destinado a isso na hora de subir... Tem que ver qual charset está sendo usado agora e mudar para um que suporte caracteres latinos (geralmente latin1). 

Deve dar para mudar tabela por tabela manualmente também, mas nunca fiz dessa forma, então não consigo orientar.

Compartilhe esta postagem


Link to post
Share on other sites
22 horas atrás, hyuga_91 disse:

Aparentemente apenas tópicos antigos antigos estão bugados, espero que arrumem pois incomoda muito ler tudo bugado, mas acho difícil que arrumem

 

praticamente todos os guias estão assim

Compartilhe esta postagem


Link to post
Share on other sites
4 horas atrás, ted_martins disse:

Para resolver esse erro, a maneira mais fácil, é subir de novo o backup do fórum e mudar o charset no campo destinado a isso na hora de subir... Tem que ver qual charset está sendo usado agora e mudar para um que suporte caracteres latinos (geralmente latin1). 

Deve dar para mudar tabela por tabela manualmente também, mas nunca fiz dessa forma, então não consigo orientar.

 

@fabriciols @GIBATSAN contrata o menino ai ó!!!  :champion:

Compartilhe esta postagem


Link to post
Share on other sites

Moderadores servem pra isso, todos eles vão passar pelos principais tópicos e alterar pelo menos os posts principais. 

:rich_guy:

Compartilhe esta postagem


Link to post
Share on other sites

Sim, vamos corrigir.

Não precisa alterar manualmente, a não ser q vc tenha pressa.

  • Curti 1
  • Valeu! 1

Compartilhe esta postagem


Link to post
Share on other sites
Em 21/06/2019 em 12:01, ted_martins disse:

Para resolver esse erro, a maneira mais fácil, é subir de novo o backup do fórum e mudar o charset no campo destinado a isso na hora de subir... Tem que ver qual charset está sendo usado agora e mudar para um que suporte caracteres latinos (geralmente latin1). 

Deve dar para mudar tabela por tabela manualmente também, mas nunca fiz dessa forma, então não consigo orientar.

 

EU acho que não funciona, o banco esta misturado com os dois chartset, o ideal é fazer replace no banco para todos os caracteres e em todas as tabelas.

 

UPDATE tabela SET coluna = replace(coluna, '’', "'");
UPDATE tabela SET coluna = replace(coluna, 'Ã', "í"); 
UPDATE tabela SET coluna = replace(coluna, 'çõ', "õe");
...

 

  • Curti 2

Compartilhe esta postagem


Link to post
Share on other sites

Crie uma conta ou entre para comentar

Você precisa ser um membro para fazer um comentário.

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×
×
  • Criar Novo...